summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 14 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc72dfcccd03..79ad44126212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgbase=linux-xanmod
_srcname=linux
-pkgver=4.14.9
-xanmod=13
+pkgver=4.14.10
+xanmod=14
pkgrel=1
arch=('x86_64')
url="http://www.xanmod.org/"
@@ -16,12 +16,15 @@ makedepends=('xmlto' 'kmod' 'inetutils' 'bc' 'libelf')
options=('!strip')
# Arch stock configuration files are directly pulled from a specific trunk
-arch_config_trunk=08b9be792b16e05a6febc3184c286c99a8088b86
+arch_config_trunk=cd56162fda382f21319573d9071dde9559eadfb8
# Arch additional patches
arch_patches=(0001-add-sysctl-to-disallow-unprivileged-CLONE_NEWUSER-by.patch
- 0001-e1000e-Fix-e1000_check_for_copper_link_ich8lan-retur.patch
- 0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch)
+ 0001-e1000e-Fix-e1000_check_for_copper_link_ich8lan-retur.patch
+ 0002-dccp-CVE-2017-8824-use-after-free-in-DCCP-code.patch
+ 0001-Revert-xfrm-Fix-stack-out-of-bounds-read-in-xfrm_sta.patch
+ 0002-xfrm-Fix-stack-out-of-bounds-read-on-socket-policy-l.patch
+ 0003-cgroup-fix-css_task_iter-crash-on-CSS_TASK_ITER_PROC.patch)
source=(https://github.com/xanmod/linux/archive/${pkgver}-xanmod${xanmod}.tar.gz
'60-linux.hook' # pacman hook for depmod
@@ -32,15 +35,18 @@ source=(https://github.com/xanmod/linux/archive/${pkgver}-xanmod${xanmod}.tar.gz
for _patch in ${arch_patches[@]} ; do source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${arch_config_trunk}") ; done
source_x86_64=("config::https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${arch_config_trunk}")
-sha256sums=('7642b5be499aa2f6fda1fd7a925d9479cec373eb437b7bf199f1615022366fe6'
+sha256sums=('a39f39a679303cb2e05d9f58ca1360b81ef0f979cfc4982647464248be2d3bfc'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
'9fd3abfb3e5e6afd5b8476e30af4d7ded762f3da2a724133cb3f26ad21c31e54'
'37b86ca3de148a34258e3176dbf41488d9dbd19e93adbd22a062b3c41332ce85'
'c6e7db7dfd6a07e1fd0e20c3a5f0f315f9c2a366fe42214918b756f9a1c9bfa3'
- '1d69940c6bf1731fa1d1da29b32ec4f594fa360118fe7b128c9810285ebf13e2')
-sha256sums_x86_64=('3d139e6cfc42a0bb52a6c49a2bb94ff523dc728b8d548178dbc0a90726eb4151')
+ '1d69940c6bf1731fa1d1da29b32ec4f594fa360118fe7b128c9810285ebf13e2'
+ 'ed3266ab03f836f57de0faf8a10ffd7566c909515c2649de99adaab2fac4aa32'
+ '64a014f7e1b4588728b3ea9538beee67ec63fb792d890c7be9cc13ddc2121b00'
+ '3d4c41086c077fbd515d04f5e59c0c258f700433c5da3365d960b696c2e56efb')
+sha256sums_x86_64=('4d12ed868b05720c3d263c8454622c67bdee6969400049d7adac7b00907ad195')
_kernelname=${pkgbase#linux}