summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e1a3dd57fcf..e9c230ea9e5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
##
## The following variables can be customized at build time. Use env or export to change at your wish
##
-## Example: env _microarchitecture=99 use_numa=n use_tracers=n use_pds=n makepkg -sc
+## Example: env _microarchitecture=98 use_numa=n use_tracers=n makepkg -sc
##
## Look inside 'choose-gcc-optimization.sh' to choose your microarchitecture
## Valid numbers between: 0 to 99
@@ -60,8 +60,8 @@ pkgbase=linux-xanmod-anbox
_major=5.13
pkgver=${_major}.0
_branch=5.x
-xanmod=1
-pkgrel=${xanmod}
+xanmod=2
+pkgrel=3
pkgdesc='Linux Xanmod with ashmem and binder enabled for Anbox'
url="http://www.xanmod.org/"
arch=(x86_64)
@@ -86,17 +86,17 @@ validpgpkeys=(
)
# Archlinux patches
-_commit="be7d4710850020de55bce930c83fa80347c02fc3"
-_patches=("sphinx-workaround.patch")
+_commit="ec9e9a4219fe221dec93fa16fddbe44a34933d8d"
+_patches=()
for _patch in ${_patches[@]}; do
- source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
+ #source+=("${_patch}::https://git.archlinux.org/svntogit/packages.git/plain/trunk/${_patch}?h=packages/linux&id=${_commit}")
+ source+=("${_patch}::https://raw.githubusercontent.com/archlinux/svntogit-packages/${_commit}/trunk/${_patch}")
done
sha256sums=('3f6baa97f37518439f51df2e4f3d65a822ca5ff016aa8e60d2cc53b95a6c89d9'
'SKIP'
- 'e829aa290b5f00812d9f496e4e3397621f9184e0c07db05d328ba83e69d1b34f'
- '1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee'
- '52fc0fcd806f34e774e36570b2a739dbdf337f7ff679b1c1139bee54d03301eb')
+ '42cb550e7b9900820bdc9f528eb60c726f19294417065bf3a0b94be06388aeb1'
+ '1ac18cad2578df4a70f9346f7c6fccbb62f042a0ee0594817fdef9f2704904ee')
export KBUILD_BUILD_HOST=${KBUILD_BUILD_HOST:-archlinux}
export KBUILD_BUILD_USER=${KBUILD_BUILD_USER:-makepkg}