aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 12 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b8bb76f416e..b9a792a0ab59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,11 @@
##
## Xanmod-ROG options:
##
-## none for now...
+## 'amd_pstate' - Setting this variable to 'n' will disable amd-pstate
+## unset/default enables the driver
+if [ -z ${amd_pstate+x} ]; then
+ amd_pstate=y
+fi
## Xanmod options:
##
@@ -275,6 +279,13 @@ prepare() {
--enable CONFIG_MODULE_COMPRESS_ZSTD
fi
+ if [ "$amd_pstate" = "n" ]; then
+ msg2 "Disabling amd-pstate driver..."
+ scripts/config --disable CONFIG_X86_AMD_PSTATE
+ else
+ scripts/config --enable CONFIG_X86_AMD_PSTATE
+ fi
+
# let user choose microarchitecture optimization target;
sh "${srcdir}/choose-gcc-optimization.sh" $_microarchitecture