summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a5a6dab163c4..6377b44c9549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Original PKGBUILD Contributor: Patrick Bartels <p4ddy.b@gmail.com>
# Thanks to Bregol
pkgname="linux-zen-git"
-pkgver=5.16.3+1061469+gf7f14d321259
+pkgver=6.6.10+1219797+g0c2d40dc6a85
_kernver=4.19.0+783746+g54d1f99f63e9
pkgdesc="Featureful kernel including various new features, code and optimizations to better suit desktops"
url="https://github.com/damentz/zen-kernel"
@@ -10,14 +10,14 @@ license=("GPL2")
makedepends=("git")
true && pkgbase="linux-zen-git"
true && pkgname=("linux-zen-git" "linux-zen-git-headers")
-arch=("x86_64")
+arch=("i686" "x86_64")
conflicts=("linux-zen")
provides=("linux-zen")
pkgrel=1
options=("!strip")
source=("linux-zen.conf"
"linux-zen.preset"
- 'zen-kernel::git+https://github.com/zen-kernel/zen-kernel.git#branch=5.16/master'
+ 'zen-kernel::git+https://github.com/zen-kernel/zen-kernel.git#branch=6.7/main'
'allow-disable-msr-lockdown.patch')
sha256sums=('6373073ad943e068478ef1373be4eb2a7e473da8743d946f1f50cd364685ab87'
'18fe6b2664a9a740544c4cb990efe5ec933d6e64caf9e5d0a6ced92af0027c2d'
@@ -53,6 +53,8 @@ pkgver() {
build() {
cd "${srcdir}/zen-kernel"
+ patch -Np1 -i "${srcdir}/allow-disable-msr-lockdown.patch"
+
# don't run depmod on 'make install'. We'll do this ourselves in packaging
sed -i '2iexit 0' scripts/depmod.sh
@@ -90,8 +92,6 @@ build() {
warning "Navigate to '${srcdir}/build'"
warning "and either run 'make menuconfig' or if you want to use an existing config,"
warning "save it as '.config' and run 'make oldconfig' in order to update it."
- warning "You could also grab the one used for the mainline zen-kernel package from "
- warning "https://raw.githubusercontent.com/archlinux/svntogit-packages/packages/linux-zen/trunk/config "
warning "Having done that you can run 'makepkg' again."
plain ""
@@ -102,9 +102,6 @@ build() {
fi
fi
- msg "Allowing disable of MSR in lockdown mode to allow undervolting and prevent false positives for spectre-meltdown-checker..."
- patch -Np1 -i "${srcdir}/allow-disable-msr-lockdown.patch"
-
msg2 "Updating output directory Makefile..."
make -C "${srcdir}/zen-kernel/" O="${srcdir}/build" outputmakefile