summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 14 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 290307aa2de3..854232c87901 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Yidaozhan Ya <yidaozhan_ya@outlook.com>
_pkgname=linuxqq
pkgname=linuxqq-nt-bwrap
-pkgver=2.0.2_510
-pkgrel=6
+pkgver=2.0.3_543
+pkgrel=1
pkgdesc="Tencent QQ NT for Linux with bubblewrap wrapper"
arch=('x86_64' 'aarch64')
url='https://im.qq.com'
@@ -14,24 +14,24 @@ provides=('qq-nt' 'linuxqq-nt')
conflicts=('linuxqq-new')
options=('!strip' '!emptydirs')
install=${_pkgname}.install
-source_x86_64=('https://dldir1.qq.com/qqfile/qq/QQNT/4691a571/QQ-v2.0.1-429_x64.deb' # 本体
- 'https://qqpatch.gtimg.cn/hotUpdate_new/release/linux-x64/2.0.2-510/2.0.2-510.zip.zip') # 热更新补丁
-source_aarch64=('https://dldir1.qq.com/qqfile/qq/QQNT/0186a650/QQ-v2.0.1-453_arm64.deb' # 本体
- 'https://qqpatch.gtimg.cn/hotUpdate_new/release/linux-arm64/2.0.2-510/2.0.2-510.zip.zip' ) # 热更新补丁
+source_x86_64=("https://dldir1.qq.com/qqfile/qq/QQNT/4691a571/QQ-v2.0.1-429_x64.deb" # 本体
+ "https://qqpatch.gtimg.cn/hotUpdate_new/release/linux-x64/${pkgver//_/-}/${pkgver//_/-}.zip.zip") # 热更新补丁
+source_aarch64=("https://dldir1.qq.com/qqfile/qq/QQNT/0186a650/QQ-v2.0.1-453_arm64.deb" # 本体
+ "https://qqpatch.gtimg.cn/hotUpdate_new/release/linux-arm64/${pkgver//_/-}/${pkgver//_/-}.zip.zip" ) # 热更新补丁
source=('start.sh' 'config.json' 'qq_channel_jsbridge_handler.desktop')
-sha256sums_x86_64=('e3aa15ff6ae089b655df3913c6020ca56726bd676995aaf29b313fbd0643ea42'
- '26059ccd89a4491083add9291398de658f98fb08a779f7ce46ac7bef8245b53f')
-sha256sums_aarch64=('70c286006dae10da06c191b5f0718d17d686a8ef792f6f72215734773f01498b'
- '556d3c9f3142dea199a6605694d5d47bb93d0b33e5c6ce8f70a69eb47b2235fc')
-sha256sums=('3e3bab8273fca8f395ea3cb9a4daea0efaeebaf34526767105885b8c99cc1a69'
- '8f6fae6fef7869dad2c309d77c9530e29dd737e63deced984f10ac379eeceb03'
- 'e9b4af9b4119876572f6fe7f48563e6b0830493a8d76e8415e15d89afe6453df')
+sha256sums_x86_64=('e3aa15ff6ae089b655df3913c6020ca56726bd676995aaf29b313fbd0643ea42' # 本体
+ '2e89bc65faa26ddeed9883b5b7e414dea100ad45b5d569365431e761f00dea84') # 热更新补丁
+sha256sums_aarch64=('70c286006dae10da06c191b5f0718d17d686a8ef792f6f72215734773f01498b' # 本体
+ '0267df2233bd03a1bd95e9571956a878c141068b2d4165d318481a3d425c0acd') # 热更新补丁
+sha256sums=('dac7d36c01c987ebca98fa4f58c61336820913baeaa6d39ace86ada8da02cacc' # start.sh
+ 'bce0e99fd8f7d22742c7fce83b00a230f2408f8d4caa45efd91b35ef0819f64d' # config.json
+ 'e9b4af9b4119876572f6fe7f48563e6b0830493a8d76e8415e15d89afe6453df') # qq_channel_jsbridge_handler.desktop
package() {
# 解压程序包
tar -xJ -f "data.tar.xz" -C "${pkgdir}"
rm -rf "${pkgdir}/opt/QQ/resources/app"
- 7z x "2.0.2-510.zip" -aoa -o"${pkgdir}/opt/QQ/resources/app"
+ 7z x "${pkgver//_/-}.zip" -aoa -o"${pkgdir}/opt/QQ/resources/app"
chmod 755 "${pkgdir}/opt/QQ/resources/app"
# 打包相关处理