summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3f96b237504b..cdec998119c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=liquidctl
pkgver=1.3.3
-pkgrel=4
+pkgrel=5
pkgdesc="Cross-platform tool and drivers for liquid coolers and other devices"
url="https://github.com/jonasmalacofilho/liquidctl"
depends=('python' 'python-setuptools' 'python-pyusb' 'python-hidapi' 'python-docopt')
@@ -15,7 +15,8 @@ sha256sums=('d13180867e07420c5890fe1110e8f45fe343794549a9ed7d5e8e76663bc10c24')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
- export DIST_NAME="$(source /etc/os-release && echo $PRETTY_NAME)"
+ # use $NAME or "generic" if $PRETTY_NAME isn't available
+ export DIST_NAME="$(source /etc/os-release && if [ -n "$PRETTY_NAME" ]; then echo "$PRETTY_NAME"; elif [ -n "$NAME" ]; then echo "$NAME"; else echo "generic"; fi)"
export DIST_PACKAGE="$pkgname $pkgver-$pkgrel"
python setup.py build
}