summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b7408d3cb6b..d7c60857651f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
# Contributor: Caleb Maclennan <caleb@alerque.com>
+# Contributor: Andrew Lorimer <andrew@lorimer.id.au>
_pkgname=listmonk
pkgname=$_pkgname-bin
-pkgver=2.5.1
-pkgrel=2
+pkgver=3.0.0
+pkgrel=1
pkgdesc='Self-hosted newsletter and mailing list manager with a modern dashboard (binary release)'
arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
url="https://github.com/knadh/listmonk"
license=('AGPL3')
depends=('postgresql')
provides=("$_pkgname")
-conflicts=("$_pkgname")
+conflicts=("$_pkgname" "$_pkgname"-git)
+options=(!strip !debug)
backup=(etc/listmonk/config.toml)
install=$_pkgname.install
source=("$_pkgname-$pkgver.toml::https://raw.githubusercontent.com/knadh/$_pkgname/v$pkgver/config.toml.sample"
@@ -19,17 +21,17 @@ source=("$_pkgname-$pkgver.toml::https://raw.githubusercontent.com/knadh/$_pkgna
"$_pkgname.service")
sha256sums=('4941b1bd6d9ebc84b4ee1f9e3cf7aa651484a8bc857864ba40eda7bb67789c18'
'5cfc186438df2408ed88a5bec3a9a4b5f2afb0d3aec41c4cc63b2f5eb810b3cb'
- '809ede70c932183889b2fa567b340fb82cce1ada76c7b0a0b9efb82b87c92fa0')
+ '4852f206b7763ba047ba123d663cadb806f437967154ebe837845198b3266533')
source_x86_64=("$url/releases/download/v${pkgver}/listmonk_${pkgver}_linux_amd64.tar.gz")
source_aarch64=("$url/releases/download/v${pkgver}/listmonk_${pkgver}_linux_arm64.tar.gz")
source_armv6h=("$url/releases/download/v${pkgver}/listmonk_${pkgver}_linux_armv6.tar.gz")
source_armv7h=("$url/releases/download/v${pkgver}/listmonk_${pkgver}_linux_armv7.tar.gz")
-sha256sums_x86_64=('552bb7cb47d7b55be7b48a4ccc19d69b96491065433dafd8cc6a0f39869e4113')
-sha256sums_aarch64=('832c5a34ed78446c179ed5423cdbce51d3e51333c1ea6cf11c74b63e0776193a')
-sha256sums_armv6h=('802a1755071e1a9c8b340984143effe9a88b49216f7711ffa00942535b2c3b76')
-sha256sums_armv7h=('7e7e96d64cd2af96711d8d3db717cfdb5c4b8c9ac3fb78b43a4704a8e5625c99')
+sha256sums_x86_64=('29c4965146231d40fb9bd2eecb469534a669262c025538788a56d5d365392cf4')
+sha256sums_aarch64=('c60a03a1ae74ad96e67eacb205d9b8c3f7dcebff164daa0a1da93e99c361b214')
+sha256sums_armv6h=('d70eab28b24d19b22c12d32fafdba56112f39950019aff9d33526e7f44ab7d69')
+sha256sums_armv7h=('8f405404901f1283b2ebddf1118f884c72883e981b3b70c2266c1cc523e48794')
package() {
install -Dm644 $_pkgname-$pkgver.toml "$pkgdir/etc/$_pkgname/config.toml"