summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e24862a4af9..287bdb301f1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
-# Maintainer: Loïc Guitaut <flink at belfalas.eu>
+# Maintainer: Radek Podgorny <radek@podgorny.cz>
+# Contributor: Loïc Guitaut <flink at belfalas.eu>
# Contributor: Nicolas Doualot <packages at slubman.info>
pkgname='litecoin-qt'
-pkgver=0.10.2.2
-pkgrel=2
+pkgver=0.13.2
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.litecoin.org/"
makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc' 'protobuf')
license=('MIT')
pkgdesc="Peer-to-peer network based digital currency (QT)"
-depends=(boost-libs qt4 miniupnpc qrencode protobuf)
+depends=(boost-libs qt5-base miniupnpc qrencode protobuf)
+makedepends=(qt5-tools)
conflicts=(litecoin)
install=litecoin-qt.install
source=("https://github.com/litecoin-project/litecoin/archive/v$pkgver.tar.gz"
- "$pkgname.desktop"
- "upnp-1.9.patch")
-sha256sums=('952c84b181323db17a8fa23217f59b576ad3ebad92c158b3a7c29d458a1130dc'
- 'cfc53dc9028745358235698ddd562d3e6b4a3ea9f896f5efc1aa8cd81f595559'
- '3060917f8e327002da842534265392a1849239ec5049f25c1ae8a81c3952e7b1')
+ "$pkgname.desktop")
+sha256sums=('b3cef44f3136fc1049c0be70fdb4562accad75b98096e76787bfcc48c91b745f'
+ 'cfc53dc9028745358235698ddd562d3e6b4a3ea9f896f5efc1aa8cd81f595559')
build() {
cd "$srcdir/litecoin-$pkgver"
- patch -p1 -i ../upnp-1.9.patch
./autogen.sh
- ./configure --with-incompatible-bdb
+ ./configure --with-incompatible-bdb --with-gui=qt5
make
}