summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--[-rwxr-xr-x]PKGBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35dbd3c0ff29..a57f64fc85bd 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,17 @@
_srcname=littleutils
pkgname=littleutils-full
pkgver=1.0.37
-pkgrel=1
-pkgdesc="Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)"
+pkgrel=2
+pkgdesc='Utilities for compression, file manipulation, text cleanup, and images/PDF optimization (with all features and extras)'
arch=('i686' 'x86_64')
-url="http://littleutils.sourceforge.net/"
-license=('custom' 'GPL3')
-depends=('bash' 'dash' 'perl' 'python2' 'file' 'gifsicle' 'libjpeg-turbo' 'libpng'
- 'pngcrush' 'bzip2' 'gzip' 'lzip' 'lzma_alone' 'lzop' 'xz' 'p7zip' 'wget'
+url='http://littleutils.sourceforge.net/'
+license=('custom')
+depends=(
+ # official repositories:
+ 'bash' 'dash' 'perl' 'python2' 'file' 'gifsicle' 'libjpeg-turbo' 'libpng'
+ 'pngcrush' 'bzip2' 'gzip' 'lzip' 'lzop' 'xz' 'p7zip' 'ghostscript' 'wget'
+ # AUR:
+ 'lzma_alone'
)
provides=('littleutils')
conflicts=('littleutils')
@@ -17,18 +21,18 @@ source=("https://sourceforge.net/projects/littleutils/files/littleutils-source/$
sha256sums=('f846ab6d2793499c99472469a2a74d9e57ee336320700bd540e2bc6ab0ec76da')
build() {
- cd "$_srcname"-"$pkgver"
-
- ./configure --prefix=/usr
-
- make
+ cd "${_srcname}-${pkgver}"
+
+ ./configure --prefix='/usr'
+
+ make
}
package() {
- cd "$_srcname"-"$pkgver"
-
- make DESTDIR="$pkgdir/" install
- make DESTDIR="$pkgdir/" install-extra
-
- install -D -m644 LICENSES "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES"
+ cd "${_srcname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" install-extra
+
+ install -D -m644 LICENSES "${pkgdir}/usr/share/licenses/${pkgname}/LICENSES"
}