summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8540540029eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Nelson Estevão <nelson@marmelasoft.com>
+pkgname="livebook"
+pkgver="0.7.2"
+pkgrel="1"
+pkgdesc="Livebook - Automate code & data workflows with interactive Elixir notebooks"
+arch=("x86_64")
+
+depends=('openssl' 'erlang' 'elixir')
+
+# sha256sums=("SKIP")
+
+build() {
+ mix do local.rebar --force, local.hex --force
+ mix escript.install hex livebook 0.7.2
+}
+
+package() {
+ # Copy the installed package to the package directory
+ sudo cp -r $HOME/.mix/escripts/livebook /usr/bin/
+}
+
+