summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f804d39cb088..67ab26096181 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
# Maintainer: Salamandar <felix@piedallu.me>
pkgname=livewallpaper
-pkgver=0.5.0
-pkgrel=1
pkgdesc="OpenGL powered animated wallpapers with configuration utility, autostart, and application indicator."
-arch=('x86_64' 'i686')
url="https://launchpad.net/livewallpaper"
license=('GPL3')
+
+pkgver=0.5.0
+pkgrel=1
+arch=('x86_64' 'i686')
+
makedepends=('intltool' 'xcftools' 'cmake' 'vala')
-depends=('libpeas' 'glew' 'upower' 'libappindicator-gtk3' 'gobject-introspection'
- 'python' 'python-cairo' 'python-opengl')
+depends=(
+ 'libpeas' 'upower' 'libappindicator-gtk3' 'gobject-introspection'
+ 'python' 'python-cairo' 'python-opengl' 'glew'
+)
+
+source=(
+ 'https://launchpad.net/livewallpaper/0.5/0.5.0/+download/livewallpaper-0.5.0.tar.gz'
+)
-provides=('livewallpaper' 'livewallpaper-indicator' 'livewallpaper-config')
-source=(https://launchpad.net/livewallpaper/0.5/0.5.0/+download/livewallpaper-0.5.0.tar.gz)
-sha256sums=('f4ce97a721015b135eb675915eb306c1fb256e680d480fe13e4fe6ca81c7e04e')
-install=livewallpaper.install
+sha256sums=(
+ 'f4ce97a721015b135eb675915eb306c1fb256e680d480fe13e4fe6ca81c7e04e'
+)
prepare() {
cd "$srcdir/$pkgname-$pkgver"