summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40e02b7cf199
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=lizard-git
+pkgver=1.0.r3.g6a1ed71
+pkgrel=1
+pkgdesc="An efficient compressor with very fast decompression"
+arch=('i686' 'x86_64')
+url="https://github.com/inikep/lizard"
+license=('GPL2' 'BSD')
+depends=('glibc')
+makedepends=('git')
+provides=('lizard')
+conflicts=('lizard')
+source=("git+https://github.com/inikep/lizard.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "lizard"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "lizard"
+
+ make
+}
+
+check() {
+ cd "lizard"
+
+ #make test
+}
+
+package() {
+ cd "lizard"
+
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+ install -Dm644 "lib/LICENSE" "$pkgdir/usr/share/licenses/lizard/LICENSE"
+}