summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5a3e8c52e071..7d11ba1e1119 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# lizardfs is a fork of moosefs and as such is a replacement for it.
pkgname=lizardfs
pkgver=3.12.0
-pkgrel=2
+pkgrel=3
pkgdesc='LizardFS is a highly reliable, scalable and efficient distributed file system. It spreads data over a number of physical servers, making it visible to an end user as a single file system.'
url='http://lizardfs.com'
conflicts=('moosefs' 'mfs-master' 'mfs-chunkserver' 'mfs-client')
arch=('x86_64' 'i686')
license=('GPL3')
-depends=('asciidoc' 'boost' 'zlib' 'fuse' 'python2' 'bash' 'cmake' 'unzip')
+depends=('asciidoc' 'boost' 'zlib' 'fuse2' 'python2' 'bash' 'cmake' 'unzip')
install="$pkgname.install"
source=("http://github.com/lizardfs/lizardfs/archive/v${pkgver}.tar.gz"
- "cmath.patch")
+ "cmath.patch"
+ "iostat.h.patch")
sha256sums=('d21220dc7542539b48d5bff7abe047a8c6bdbab19cb03579f88f146dee3ec5f6'
- 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c')
+ 'fd9e8e3e0bfbb3d1befb3a6136d9257dcebb60cd49012051773e35b355ce0d5c'
+ 'ff4fb9bad5be91fa9d8214a57c782586e6232793cfc54503e1678519fd242984')
prepare() {
cd "lizardfs-${pkgver%_*}"
patch -Np1 -i $srcdir/cmath.patch
+ patch -Np1 -i $srcdir/iostat.h.patch
}
build() {