summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c7f4b93da6b3..dcdd76b96b05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,9 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/Perl_Package_Guidelines for more
-# information on Perl packaging.
-
-# Contributor: Your Name <youremail@domain.com>
+# Maintainer: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
pkgname=llgal
-pkgver=0.13.17
+pkgver=0.13.18
pkgrel=1
pkgdesc="On-line gallery generator based on iGal"
-arch=(x86_64)
+arch=('i686' 'x86_64')
url="http://home.gna.org/llgal/"
license=('GPL')
depends=('perl' 'perl-image-size' 'perl-locale-gettext')
@@ -23,7 +15,7 @@ backup=()
options=(!emptydirs)
install=
source=(http://download.gna.org/llgal/$pkgname-$pkgver.tar.bz2)
-md5sums=('3d42aaebcea39d0841ef6777a24ace41')
+md5sums=('160f03cfb34012bc240f0c8314edbd00')
package() {
cd "$srcdir/$pkgname-$pkgver"
@@ -31,6 +23,9 @@ package() {
sed -i 's/\/usr\/local/\/usr/g' Makefile
make || return 1
make install DESTDIR="$pkgdir/" || return 1
+ make install-man DESTDIR="$pkgdir/" || return 1
+ make install-doc DOCDIR="$pkgdir/usr/share/doc/llgal" || return 1
+
# remove perllocal.pod and .packlist
find "$pkgdir" -name perllocal.pod -delete