summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c720f66a8527
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+
+pkgname="linux-proton-bin"
+pkgver=11.0.0
+pkgrel=1
+arch=(
+ "x86_64"
+)
+pkgdesc="A LLVM and Clang compiler toolchain built for kernel development"
+url="https://github.com/kdrag0n/proton-clang"
+license=(
+ "custom"
+)
+options=(
+ "!strip"
+)
+source=(
+ "https://github.com/kdrag0n/proton-clang/archive/master.zip"
+)
+b2sums=(
+ "SKIP"
+)
+
+package()
+{
+ install -d "$pkgdir/opt"
+
+ cp -r "proton-clang-master" "$pkgdir/opt/proton-clang"
+}