summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e2a103d6942
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: SY.Zhang <lastavengers@archlinuxcn.org>
+pkgname=loc
+pkgver=0.3.2
+pkgrel=1
+pkgdesc='Count lines of code quickly'
+arch=('x86_64' 'i386')
+url='https://github.com/cgag/loc'
+license=('MIT')
+makedepends=('cargo-nightly' 'git')
+source=("https://github.com/cgag/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('SKIP')
+
+build () {
+ cd ${pkgname}-${pkgver}
+ cargo build --release
+}
+
+package () {
+ cd ${pkgname}-${pkgver}/target/release
+ install -Dm755 ${pkgname} ${pkgdir}/usr/bin/${pkgname}
+}