summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 23 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2bb4126b4aa..7ae8e10bfdd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,41 @@
-# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Maintainer: Chih-Hsuan Yen <base64_decode("eXUzYWN0eHQydHR0ZmlteEBjaHllbi5jYwo=")>
# Contributor: Thomas Weißschuh <thomas t-8ch de>
pkgname=logcat-color3
-pkgver=0.9.0
-pkgrel=3
+pkgver=0.10.0
+# curl https://api.github.com/repos/yan12125/logcat-color3/git/ref/tags/v$pkgver | jq -r .object.sha
+_tag=ee5c73183b4ab58e0103bddbe1119632ce43e500
+pkgrel=2
pkgdesc='A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK'
arch=(any)
url='https://github.com/yan12125/logcat-color3'
-license=(Apache)
-depends=(python-colorama)
-makedepends=(python-setuptools-scm)
+# https://github.com/yan12125/logcat-color3/blob/v0.10.0/setup.cfg#L11
+license=('Apache-2.0')
+depends=(python python-colorama python-pyasyncore python-pyasynchat)
+makedepends=(git python-build python-installer python-setuptools python-setuptools-scm python-wheel)
conflicts=(logcat-color)
-source=("https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-$pkgver.tar.gz"{,.asc})
-sha256sums=('57471841b59d0a456f6d3a971bb3701ca2fc9a8319735e9515c9de3cd2062c92'
- 'SKIP')
+source=("git+https://github.com/yan12125/logcat-color3?signed#tag=$_tag")
+sha256sums=('b86493ccd1c6e763e6dbc8cfed12baca3fd0ca4b48ccd6ec0755e418fddce7e6')
validpgpkeys=(
- '481C4474AF1572165AE4C6AF3FDDD575826C5C30' # Chih-Hsuan Yen <yan12125@gmail.com>
+ 'E62545315B012B69C8C94A1D56EC201BFC794362'
)
+pkgver() {
+ cd logcat-color3
+ git describe --tags | sed 's/^v//'
+}
+
build() {
- cd logcat-color3-$pkgver
- python setup.py build
+ cd logcat-color3
+ python -m build --wheel --no-isolation
}
check() {
- cd logcat-color3-$pkgver
- python test/test.py
+ cd logcat-color3
+ python -m unittest discover ./test
}
package() {
- cd logcat-color3-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd logcat-color3
+ python -m installer --destdir="$pkgdir" dist/*.whl
}