summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a113bea5ae5..fed0cbead08d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,39 @@
# Contributor: Thomas Weißschuh <thomas t-8ch de>
pkgname=logcat-color3
-pkgver=0.9.2
+pkgver=0.10.0
+# curl https://api.github.com/repos/yan12125/logcat-color3/git/ref/tags/v$pkgver | jq -r .object.sha
+_tag=ee5c73183b4ab58e0103bddbe1119632ce43e500
pkgrel=1
pkgdesc='A colorful and highly configurable alternative to the standard "adb logcat" command from the Android SDK'
arch=(any)
url='https://github.com/yan12125/logcat-color3'
license=(Apache)
depends=(python python-colorama)
-makedepends=(python-setuptools-scm python-wheel)
+makedepends=(git python-build python-installer python-setuptools python-setuptools-scm python-wheel)
conflicts=(logcat-color)
-source=("https://files.pythonhosted.org/packages/source/l/logcat-color3/logcat-color3-$pkgver.tar.gz"{,.asc})
-sha256sums=('a1da09de689470c323576014e7644f4987e7866846d1a785b53eab2a324dcb40'
- 'SKIP')
+source=("git+https://github.com/yan12125/logcat-color3?signed#tag=$_tag")
+sha256sums=('SKIP')
validpgpkeys=(
'E62545315B012B69C8C94A1D56EC201BFC794362' # Chih-Hsuan Yen <yan12125@archlinux.org>
)
+pkgver() {
+ cd logcat-color3
+ git describe --tags | sed 's/^v//'
+}
+
build() {
- cd logcat-color3-$pkgver
- python setup.py build
+ cd logcat-color3
+ python -m build --wheel --no-isolation
}
check() {
- cd logcat-color3-$pkgver
+ cd logcat-color3
python -m unittest discover ./test
}
package() {
- cd logcat-color3-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd logcat-color3
+ python -m installer --destdir="$pkgdir" dist/*.whl
}