summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3bdcb12f3ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Michael Kogan <michael dot kogan at gmx dot net>
+
+pkgname='logsgui-git'
+pkgdesc='Simple GUI to show log files in a graphical editor, git version'
+pkgver=r90.d5287e2
+pkgrel=1
+
+depends=('python-pyqt4' 'python-sh' 'xdg-utils')
+optdepends=('inxi: Show system information'
+ 'xorg: Show Xorg log'
+ 'systemd: Show systemd log'
+ 'mhwd: Show driver information using mhwd from Manjaro Linux' )
+makedepends=('git')
+
+source=("git+https://github.com/AlManja/logs.py.git")
+md5sums=('SKIP')
+
+arch=('any')
+url='https://github.com/AlManja/logs.py'
+license=('MIT')
+
+package() {
+ install -d -m755 "$pkgdir/usr/bin"
+ install -m 755 "$srcdir/logs.py/logsgui.py" "$pkgdir/usr/bin/logsgui"
+}
+
+pkgver() {
+ cd "logs.py"
+ printf -- "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+} \ No newline at end of file