summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d38cf90a8c4..7df1b0cd9d30 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,29 @@
# Maintainer: Charlie Ringström <c.ringstrom@gmail.com>
pkgname='longcat'
-pkgver=r117.62bfdec
+pkgver=v0.0.4
pkgrel=2
-pkgdesc="Creates a loooonng cat in the terminal"
-arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+pkgdesc="Creates a looooong cat in the terminal"
+arch=('any')
url="https://github.com/mattn/longcat"
license=('MIT')
depends=('glibc')
-makedepends=('go')
+makedepends=('go' 'git')
#changelog="Initial release"
-source=("longcat::git://github.com/mattn/longcat.git")
+source=("longcat::git+https://github.com/mattn/longcat.git#tag=$pkgver")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ git describe --tags
}
build() {
cd "$pkgname"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
go build -o longcat
}