summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76c69bf020c7..adec8aab6767 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,24 +2,30 @@
# Co-Maintainer: Martin Rys <https://rys.pw/contact>
pkgname=loot
-pkgver=0.20.0
-_pkglibver=0.19.4
+pkgver=0.21.0
+_pkglibver=0.21.0
pkgrel=1
pkgdesc="A load order optimisation tool for the Elder Scrolls (Morrowind and later) and Fallout (3 and later) games."
arch=('x86_64')
url="https://loot.github.io"
license=('GPL3')
-depends=('boost-libs' 'libssh2' 'alsa-lib' 'nss' 'pango' 'atk' 'libxdamage' 'libxcomposite' 'libxcursor' 'libxrandr' 'libxss' 'libxtst' 'qt5-base')
+depends=('boost-libs' 'libssh2' 'alsa-lib' 'nss' 'pango' 'atk' 'libxdamage' 'libxcomposite' 'libxcursor' 'libxrandr' 'libxss' 'libxtst' 'qt6-base')
makedepends=('git' 'cmake' 'rust' 'cbindgen' 'boost' 'onetbb')
source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/$pkgver.tar.gz"
"lib$pkgname-$_pkglibver.tar.gz::https://github.com/$pkgname/lib$pkgname/archive/$_pkglibver.tar.gz"
'LOOT.desktop'
)
-sha256sums=('25b09d8a4ae94887eb889865c889472618207c4728b12c7d252fc58ded1f9c7f'
- '819c0c8a6986a612c81729cccf51a848dac7d83f46a75d93cfbb87587f86635e'
+sha256sums=('e729a1da8ae6eb28a444370c7dbe3f0eb6c502fe99cce96487935a70df4e713d'
+ '9cdf082670b71d1f3c89e3916e9dbc3a41a12cc74f55613a897a93f1c9f4a267'
'3dd063fdbe33dc82a4298bd5bcd3b4e7490adab4128389c153d12c6b074b27fb'
)
+# https://github.com/loot/loot/issues/1920
+prepare() {
+ sed -i 's/ICU 71.1 EXACT/ICU 71.1/' "${srcdir}/${pkgname}-${pkgver}/CMakeLists.txt"
+ sed -i 's/ICU 71.1 EXACT/ICU 71.1/' "${srcdir}/lib${pkgname}-${pkgver}/CMakeLists.txt"
+}
+
build() {
# libloot
cd "$srcdir/lib$pkgname-$_pkglibver"