summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 26 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 01de6940fc46..83315b46424c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Generated by pakanton
# Maintainer: Branislav HolĂ˝ <branoholy@gmail.com>
-pkgname=lsl-registration
-pkgver=0.1.3
-pkgrel=1
-pkgdesc="A library for working with LIDAR data"
+pkgbase='lsl-registration'
+pkgname=('lsl-registration' 'lsl-registration-lib')
+pkgver='0.1.3'
+pkgrel='2'
+pkgdesc='A library for working with LIDAR data'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/branoholy/lsl"
+url='https://github.com/branoholy/lsl'
license=('GPL3')
-makedepends=('cmake>=2.8' 'boost>=1.54')
-depends=('lsl-core>=0.1.3' 'lsl-registration-lib>=0.1.3')
+makedepends=('cmake>=2.8' 'lsl-core>=0.1.3' 'boost>=1.54')
source=("https://github.com/branoholy/lsl/archive/v$pkgver/lsl-$pkgver.tar.gz"
"https://github.com/branoholy/lsl/releases/download/v$pkgver/lsl-$pkgver.tar.gz.sig")
md5sums=('1bfbf88bcccc81c519dab49c4e57d07c'
@@ -23,12 +23,28 @@ validpgpkeys=('D25809BF3563AA56A12B0F4D545EDD46FBAC61E6')
build() {
cd lsl-$pkgver
- mkdir -p build && cd build
+
+ mkdir -p builds/lsl-registration && cd builds/lsl-registration
cmake -Dinstall-headers:bool=on -Dlibrary:string=registration -DCMAKE_INSTALL_PREFIX=/usr ..
make
+
+ mkdir -p ../lsl-registration-lib && cd ../lsl-registration-lib
+ cmake -Dinstall-library:bool=on -Dlibrary:string=registration -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package_lsl-registration() {
+ pkgdesc='A library for working with LIDAR data - development headers'
+ depends=("lsl-core>=$pkgver" "lsl-registration-lib=$pkgver")
+
+ cd lsl-$pkgver/builds/$pkgname
+ make DESTDIR="$pkgdir/" install
}
-package() {
- cd lsl-$pkgver/build
+package_lsl-registration-lib() {
+ pkgdesc='A library for working with LIDAR data - runtime library'
+ depends=("lsl-core-lib>=$pkgver" 'yaml-cpp>=0.5')
+
+ cd lsl-$pkgver/builds/$pkgname
make DESTDIR="$pkgdir/" install
}