summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0567bf398568..e3242c1d4bda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_rockname=cassowary
_project=$_rockname.lua
-pkgname=("lua-$_rockname-git" "lua52-$_rockname-git" "lua51-$_rockname-git")
-pkgver=2.2.r26.g63e91d4
+pkgname=("lua-$_rockname-git" "lua53-$_rockname-git" "lua52-$_rockname-git" "lua51-$_rockname-git")
+pkgver=2.2.r30.gdd236e3
_branch='master'
_rockrel=0
-pkgrel=3
+pkgrel=1
pkgdesc='The cassowary constraint solver'
arch=('i686' 'x86_64')
url="https://github.com/sile-typesetter/$_project"
license=('MIT')
_lua_deps=('penlight')
-makedepends=('git' 'lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('git' 'lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("git+$url.git#branch=$_branch")
sha256sums=('SKIP')
@@ -31,6 +31,13 @@ package_lua-cassowary-git() {
depends=('lua' "${_lua_deps[@]/#/lua-}")
provides=("${pkgname/-git}")
conflicts=("${pkgname/-git}")
+ _package_helper 5.4
+}
+
+package_lua53-cassowary-git() {
+ depends=('lua53' "${_lua_deps[@]/#/lua53-}")
+ provides=("${pkgname/-git}")
+ conflicts=("${pkgname/-git}")
_package_helper 5.3
}