summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cde3f65011a7..05ceccb05771 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Contributor: Ivy Foster <code@escondida.tk>
pkgname=lua-cosmo-git
-pkgver=16.06.04
+pkgver=9.02.22.r35.ge774f08
pkgrel=1
pkgdesc='Safe templates for Lua'
arch=(i686 x86_64)
@@ -17,7 +17,13 @@ conflicts=(lua-cosmo)
source=('git+https://github.com/mascarenhas/cosmo.git')
md5sums=(SKIP)
+pkgver() {
+ cd cosmo
+ git describe | sed 's,v,,; s,-\(.*\)-,.r\1.,'
+}
+
package() {
+ cd cosmo
luarocks --tree="$pkgdir/usr" install --deps-mode=none cosmo
find "$pkgdir/usr" -name manifest -delete
}