summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 30abb9f8747c..132e5bf938df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,11 +10,16 @@ license=('ISC')
depends=('discount')
makedepends=('luarocks')
source=("https://github.com/craigbarnes/lua-discount/archive/${pkgver}.tar.gz"
- "https://luarocks.org/manifests/craigb/discount-${pkgver}-1.rockspec")
+ "https://luarocks.org/manifests/craigb/discount-${pkgver}-1.rockspec"
+ 'LICENSE::https://github.com/craigbarnes/lua-discount/raw/master/LICENSE')
sha256sums=('3531eeddde4a89d5b7a4ab9b359a7f01a88ac85dd4fac61554eb199165cfdead'
- 'edb216e8a28534f18d8950779b50dab083c8f339eaed90b68814b97c27af8255')
+ 'edb216e8a28534f18d8950779b50dab083c8f339eaed90b68814b97c27af8255'
+ '8b2fffc6b27a33bf6958a2a2293ce19ce5cbd7206ccb6dda7a9d3abe6f80c9fa')
prepare() {
+ if [[ -f "${srcdir}/lua-discount-${pkgver}/discount-${pkgver}-1.rockspec" ]]; then
+ rm "${srcdir}/lua-discount-${pkgver}/discount-${pkgver}-1.rockspec"
+ fi
ln -s "${srcdir}/discount-${pkgver}-1.rockspec" "${srcdir}/lua-discount-${pkgver}/"
}
@@ -33,7 +38,7 @@ package_lua-discount() {
pkgdesc='Lua bindings for the Discount Markdown library for Lua 5.3'
luarocks install --lua-version=5.3 --tree="$pkgdir/usr/" --deps-mode=none 5.3/*.rock
-
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.3/manifest"
}
@@ -42,7 +47,7 @@ package_lua51-discount() {
pkgdesc='Lua bindings for the Discount Markdown library for Lua 5.1'
luarocks install --lua-version=5.1 --tree="$pkgdir/usr/" --deps-mode=none 5.1/*.rock
-
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.1/manifest"
}
@@ -51,7 +56,7 @@ package_lua52-discount() {
pkgdesc='Lua bindings for the Discount Markdown library for Lua 5.2'
luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none 5.2/*.rock
-
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# remove luarocks-created root manifest
rm "$pkgdir/usr/lib/luarocks/rocks-5.2/manifest"
} \ No newline at end of file