summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ce3eef6e6fc6..0a7bab7996e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
# Contributor: Alfredo Palhares <masterkorp@masterkorp.net>
_rockname=dkjson
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=2.5
-pkgrel=3
+pkgrel=4
_rockrel=2
pkgdesc='David Kolf’s Pure Lua JSON module with UTF-8 support and no external dependencies'
arch=('any')
url="http://dkolf.de/src/$_rockname-lua.fsl/home"
license=('MIT')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("http://dkolf.de/src/$_rockname-lua.fsl/tarball/$_rockname-$pkgver.tar.gz")
sha256sums=('b469e80daa9f2355c675d9293e831f3f69153e49856c59634db97899121a720d')
@@ -24,6 +24,11 @@ _package_helper() {
package_lua-dkjson() {
depends+=('lua')
+ _package_helper 5.4
+}
+
+package_lua53-dkjson() {
+ depends+=('lua53')
_package_helper 5.3
}