summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 618d84dba354..ce3eef6e6fc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,19 +6,20 @@
_rockname=dkjson
pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=2.5
-pkgrel=2
+pkgrel=3
_rockrel=2
pkgdesc='David Kolf’s Pure Lua JSON module with UTF-8 support and no external dependencies'
arch=('any')
url="http://dkolf.de/src/$_rockname-lua.fsl/home"
license=('MIT')
-makedepends=('luarocks')
+makedepends=('lua' 'lua52' 'lua51' 'luarocks')
source=("http://dkolf.de/src/$_rockname-lua.fsl/tarball/$_rockname-$pkgver.tar.gz")
sha256sums=('b469e80daa9f2355c675d9293e831f3f69153e49856c59634db97899121a720d')
_package_helper() {
cd "$_rockname-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "$_rockname-$pkgver-$_rockrel.rockspec"
}
package_lua-dkjson() {