summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ccdd316c728..fe1bcc708809 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_rockname=fluent
_project=$_rockname-lua
-pkgname=("lua-$_rockname-git" "lua52-$_rockname-git" "lua51-$_rockname-git")
-pkgver=0.0.4.r69.g690b347
+pkgname=("lua-$_rockname-git" "lua53-$_rockname-git" "lua52-$_rockname-git" "lua51-$_rockname-git")
+pkgver=0.0.4.r75.g382a1a2
_branch='master'
_rockrel=0
-pkgrel=4
+pkgrel=1
pkgdesc='Lua implementation of Project Fluent'
arch=('any')
url="https://github.com/alerque/$_project"
license=('MIT')
_lua_deps=('cldr' 'luaepnf' 'penlight')
-makedepends=('git' 'lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('git' 'lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("git+$url.git#branch=$_branch")
sha256sums=('SKIP')
@@ -31,6 +31,13 @@ package_lua-fluent-git() {
depends=('lua' "${_lua_deps[@]/#/lua-}")
provides=("${pkgname/-git}")
conflicts=("${pkgname/-git}")
+ _package_helper 5.4
+}
+
+package_lua53-fluent-git() {
+ depends=('lua53' "${_lua_deps[@]/#/lua53-}")
+ provides=("${pkgname/-git}")
+ conflicts=("${pkgname/-git}")
_package_helper 5.3
}