summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 19c53fa45005..f6f67f922a1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aaron McDaniel (mcd1992) <'aur' at the domain 'fgthou.se'>
pkgname=lua-penlight-git
-pkgver=1.5.4.r6.g2fb9b30
+pkgver=1.5.4.r43.gee381b7
pkgrel=1
pkgdesc='A set of pure Lua libraries focusing on input data handling, functional programming, and OS path management'
url='https://github.com/stevedonovan/Penlight'
@@ -22,16 +22,11 @@ pkgver() {
package() {
cd ${pkgname}
install -dm644 "${pkgdir}/usr/share/doc/${pkgname}/" # Create doc directory
- cp -a doc/manual examples "${pkgdir}/usr/share/doc/${pkgname}/" # Copy documentation and examples into doc/
- cp -a doc/config.ld "${pkgdir}/usr/share/doc/${pkgname}/examples" # Copy example config.ld to examples
+ cp -a docs/manual examples "${pkgdir}/usr/share/doc/${pkgname}/" # Copy documentation and examples into doc/
+ cp -a config.ld "${pkgdir}/usr/share/doc/${pkgname}/" # Copy config.ld to examples
install -DTpm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md" # Copy license file and create directory
- # Find which 5.x lua versions are installed on this system
- INSTALLED_LUA_VERSIONS=`find /usr/share/lua -maxdepth 1 -type d -iname "5.*" -printf "%f\n"`
-
- # Install the actual libraries into any 5.x version path
- while read -r luaversion; do
- mkdir -p "${pkgdir}/usr/share/lua/${luaversion}/pl"
- cp -a lua/pl/* "${pkgdir}/usr/share/lua/${luaversion}/pl"
- done <<< $INSTALLED_LUA_VERSIONS
+ luaversion=`lua -v | awk '{print tolower($1$2)}' | sed -r 's/lua([0-9]\.[0-9]).*/\1/g'`
+ mkdir -p "${pkgdir}/usr/share/lua/${luaversion}/pl"
+ cp -a lua/pl/* "${pkgdir}/usr/share/lua/${luaversion}/pl"
}