summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed3203566f90..c2347b2961b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
_pkgname=penlight
-pkgname=("lua-${_pkgname}-git" "lua52-${_pkgname}-git" "lua51-${_pkgname}-git")
+pkgname=("lua-$_pkgname-git" "lua52-$_pkgname-git" "lua51-$_pkgname-git")
pkgver=1.7.0.r4.ge469fa0
pkgrel=2
pkgdesc='Lua libraries for on input data handling, functional programming, and OS interface'
@@ -10,27 +10,27 @@ url='https://tieske.github.io/Penlight'
arch=('any')
license=('MIT')
_lua_deps=('filesystem')
-source=("${_pkgname}::git+https://github.com/Tieske/Penlight.git")
+source=("$_pkgname::git+https://github.com/Tieske/Penlight.git")
sha256sums=('SKIP')
pkgver() {
- cd ${_pkgname}
+ cd "$_pkgname"
git describe --tags --abbrev=7 HEAD | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
check() {
- cd ${_pkgname}
- export LUA_PATH="${PWD}/lua/?/init.lua;${PWD}/lua/?.lua;$(lua -e 'print(package.path)')"
+ cd "$_pkgname"
+ export LUA_PATH="$PWD/lua/?/init.lua;$PWD/lua/?.lua;$(lua -e 'print(package.path)')"
lua run.lua
}
_package_helper() {
- cd ${_pkgname}
- install -Dm 644 lua/pl/* -t "${pkgdir}/usr/share/lua/$1/pl"
- install -Dm 644 CONTRIBUTING.md CHANGELOG.md README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
- install -Dm 644 docs/manual/* -t "${pkgdir}/usr/share/doc/${pkgname}/manual"
- install -Dm 644 examples/* -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
- install -Dm 644 LICENSE.md -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd "$_pkgname"
+ install -Dm 644 lua/pl/* -t "$pkgdir/usr/share/lua/$1/pl"
+ install -Dm 644 CONTRIBUTING.md CHANGELOG.md README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 docs/manual/* -t "$pkgdir/usr/share/doc/$pkgname/manual"
+ install -Dm 644 examples/* -t "$pkgdir/usr/share/doc/$pkgname/examples"
+ install -Dm 644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
}
package_lua-penlight-git() {