summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08346d226599..989246cd398d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
_rockname=serpent
_pkgname=lua-serpent
-pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
+pkgname=("lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=0.28
_rockrel=1
-pkgrel=3
+pkgrel=4
pkgdesc='Lua serializer and pretty printer'
arch=('i686' 'x86_64')
url="https://github.com/pkulchenko/$_rockname"
license=('MIT')
-makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+makedepends=('lua' 'lua53' 'lua52' 'lua51' 'luarocks')
source=("$_rockname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('93c35fc1941d300268ba2d4eca4a80a8c9965c789e1150678d7d68158e1f2fef')
@@ -22,6 +22,11 @@ _package_helper() {
package_lua-serpent() {
depends+=('lua')
+ _package_helper 5.4
+}
+
+package_lua53-serpent() {
+ depends+=('lua53')
_package_helper 5.3
}