summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9907ee705a77..bf3120b39a1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,21 @@ pkgbase=lua-$_rockname
pkgname=("lua-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
_pkgname=_debug
pkgver=1.0.1
-pkgrel=2
+pkgrel=3
_rockrel=1
-pkgdesc="Lua Debug Hints Library"
+pkgdesc='Lua Debug Hints Library'
arch=('any')
url="https://github.com/lua-stdlib/$_pkgname"
license=('MIT')
-makedepends=('luarocks')
-source=("$pkgbase-$pkgver.tar.gz::https://github.com/lua-stdlib/$_pkgname/archive/v$pkgver.tar.gz")
+makedepends=('lua' 'lua52' 'lua51' 'luarocks')
+source=("$pkgbase-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('efc560540f08dcf880ac48c6ab527bd741bbe3d6d66202a3c8be3ff5c9e1e907')
_package_helper() {
cd "$_pkgname-$pkgver"
- luarocks --lua-version="$1" --tree="$pkgdir/usr/" make --deps-mode=none --no-manifest "${_rockname/-/.}-$pkgver-$_rockrel.rockspec"
- install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ luarocks --lua-version="$1" --tree="$pkgdir/usr/" \
+ make --deps-mode=none --no-manifest "${_rockname/-/.}-$pkgver-$_rockrel.rockspec"
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE.md
}
package_lua-std-_debug() {