summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c0b2d425e49..31f9b253e6e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=lua52-base64
pkgver=1.5.3
-pkgrel=1
+pkgrel=2
pkgdesc='LUA JWT Jitsi'
arch=('any')
url='https://github.com/iskolbin/lbase64'
license=('MIT')
makedepends=('luarocks' 'lua52')
-source=("git+https://github.com/iskolbin/lbase64#tag=v${pkgver}")
-sha256sums=('SKIP')
+source=("https://github.com/iskolbin/lbase64/archive/refs/tags/v${pkgver}.tar.gz")
build() {
- cd "lbase64"
+ cd "lbase64-${pkgver}"
luarocks make --pack-binary-rock --lua-version="5.2" --deps-mode=none rockspec/base64-1.5-3.rockspec
}
package() {
- cd "lbase64"
+ cd "lbase64-${pkgver}"
luarocks install --lua-version=5.2 --tree="$pkgdir/usr/" --deps-mode=none --no-manifest *.rock
}
+sha256sums=('2c4db293cc6f76ef14bf051afd74fe347e7b39f85e825431e5f786e70ff76bae')