summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e7114711e20..79e8f4b2304d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,6 @@
# Contributor: Sébastien Luttringer <seblu@archlinux.org>
# Contributor: Alain Kalker <a dot c dot kalker at gmail dot com>
-_pkgbase=lgi
pkgname=('luajit-lgi')
pkgver=0.9.2
pkgrel=1
@@ -14,25 +13,23 @@ arch=('x86_64')
license=('MIT')
depends=('glibc' 'glib2' 'libffi' 'luajit' 'gobject-introspection-runtime')
makedepends=('gobject-introspection')
-replaces=('lgi')
-conflicts=('lgi')
-source=(${_pkgbase}-${pkgver}.tar.gz::https://github.com/pavouk/lgi/archive/${pkgver}.tar.gz)
+source=(lgi-${pkgver}.tar.gz::https://github.com/pavouk/lgi/archive/${pkgver}.tar.gz)
sha512sums=('755a96b78530f42da6d4e2664f8e37cb07a356419e7e6448003c3f841c9d98ad18b851715d9eb203ea7eb27b13ec46223fa8a1c90a99fd12960ce85b0a695335')
build() {
- cd ${_pkgbase}-${pkgver}
+ cd lgi-${pkgver}
make LUA_INCDIR=/usr/include/luajit-2.0/ \
LUA_CFLAGS="$(pkg-config --cflags luajit) -O2"
}
check() {
- cd ${_pkgbase}-${pkgver}
+ cd lgi-${pkgver}
# TODO: fix cairo-gobject dependency
# make check
}
package_luajit-lgi() {
- cd ${_pkgbase}-${pkgver}
+ cd lgi-${pkgver}
make \
LUA_LIBDIR=/usr/lib/lua/5.1 \
LUA_SHAREDIR=/usr/share/lua/5.1 \