summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cda7bcd9b5bf..c538f6f79ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
pkgname=lugaru
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A third-person action game featuring a unique close-range combat system"
url="https://osslugaru.gitlab.io"
license=('GPL')
arch=('i686' 'x86_64')
depends=('sdl2' 'glu' 'libjpeg-turbo' 'libpng' 'openal' 'libvorbis' 'zlib')
makedepends=('cmake')
-conflicts=('lugaru-hg')
+options=('!optipng')
+conflicts=('lugaru-hg' 'lugaruhd-hg')
source=("${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/osslugaru/lugaru/repository/archive.tar.bz2?ref=${pkgver}"
"${pkgname}.desktop")
sha256sums=('4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7'
@@ -16,12 +17,14 @@ sha256sums=('4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7'
build() {
cd $srcdir/lugaru-1.1-53bbd7b11ba7558692b00d936d3103750fcb430b/
- mkdir build
+ mkdir build || true
cd build
cmake -DSYSTEM_INSTALL=ON \
- -DCMAKE_INSTALL_BINDIR=games \
- -DCMAKE_INSTALL_DATADIR=share/games \
- -DCMAKE_INSTALL_MANDIR=../man \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_BINDIR=bin \
+ -DCMAKE_INSTALL_DATADIR=share \
+ -DCMAKE_INSTALL_MANDIR=share/man \
..
make
}