summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 26 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06a9bf49aa52..cda7bcd9b5bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
-# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
pkgname=lugaru
-pkgver=1.0c
-pkgrel=3
-pkgdesc="A third-persion action game featuring a unique close-range combat system"
-url="http://www.wolfire.com/lugaru"
-license=('custom')
+pkgver=1.1
+pkgrel=1
+pkgdesc="A third-person action game featuring a unique close-range combat system"
+url="https://osslugaru.gitlab.io"
+license=('GPL')
arch=('i686' 'x86_64')
-depends=('gcc-libs' 'openal' 'sdl')
-source=("${pkgname}-${pkgver}.zip::http://cdn.wolfire.com/games/${pkgname}/${pkgname}-linux-x86-${pkgver}.bin"
- "${pkgname}.launcher"
+depends=('sdl2' 'glu' 'libjpeg-turbo' 'libpng' 'openal' 'libvorbis' 'zlib')
+makedepends=('cmake')
+conflicts=('lugaru-hg')
+source=("${pkgname}-${pkgver}.tar.bz2::https://gitlab.com/osslugaru/lugaru/repository/archive.tar.bz2?ref=${pkgver}"
"${pkgname}.desktop")
-sha256sums=('ad330c9f5496a1fc54fb3640723420a80dfee9da47a71ef7a34a38848c885ade'
- 'c8a8bb5be74806f7c7aeef5839a7de549dbabb95edd4394063d7ad6572d88e04'
- '306df52e81c544ed8884f52d4c6392c9d0de8d82ea3c68a53d7d3d924d1780d9')
+sha256sums=('4372ef81494365f7227a72051960f3940acf8418006dbdb05c83d12232f481e7'
+ 'c97bbd82701c07692f35fd86d0a4b4fdb2d5380a5672dde75617ae15389bfd15')
+
+build() {
+ cd $srcdir/lugaru-1.1-53bbd7b11ba7558692b00d936d3103750fcb430b/
+ mkdir build
+ cd build
+ cmake -DSYSTEM_INSTALL=ON \
+ -DCMAKE_INSTALL_BINDIR=games \
+ -DCMAKE_INSTALL_DATADIR=share/games \
+ -DCMAKE_INSTALL_MANDIR=../man \
+ ..
+ make
+}
package() {
- install -d "${pkgdir}/opt/${pkgname}"
- cp -a --no-preserve=ownership data/* "${pkgdir}/opt/${pkgname}"
-
- install -Dm755 "${srcdir}/${pkgname}.launcher" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "data/${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ cd $srcdir/lugaru-1.1-53bbd7b11ba7558692b00d936d3103750fcb430b/build
+ make DESTDIR="$pkgdir/" install
+
}