summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 834f63423ba0..be9ee5ce4a2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Frederik “Freso” S. Olesen <freso.dk@gmail.com>
# Contributor: Maxime Gauduin <alucryd@archlinux.org>
pkgname=lutris-git
-pkgver=0.5.16.r493.gfa0454724
+pkgver=0.5.17.r1.ge8bfc73bb
pkgrel=1
pkgdesc='Open Gaming Platform'
arch=('any')
@@ -33,21 +33,21 @@ depends=(
'python-yaml'
'unzip'
'webkit2gtk-4.1'
- 'xdg-desktop-portal-impl'
'xdg-utils'
'xorg-xrandr'
)
makedepends=('git' 'meson')
checkdepends=(
- 'appstream'
+ 'appstream-glib'
# 'fluidsynth'
# 'pciutils'
-# 'python-nose-cover3'
+# 'python-nose'
# 'vulkan-tools'
# 'xorg-server-xvfb'
# 'xterm'
)
optdepends=(
+ 'fluidsynth'
'gamemode: Allows games to request a temporary set of optimisations'
'gamescope: Draw the game window isolated from your desktop'
'gvfs: GVFS backend'
@@ -67,7 +67,8 @@ optdepends=(
'vulkan-icd-loader: Vulkan support'
'vulkan-tools: Vulkan support'
'wine: easiest way to get all the libraries missing from the Lutris runtime'
- 'winetricks: use system winetricks')
+ 'winetricks: use system winetricks'
+ 'xdg-desktop-portal-impl')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=('git+https://github.com/lutris/lutris.git')
@@ -91,13 +92,7 @@ check() {
meson test -C build --print-errorlogs
# cd "${pkgname%-git}"
-# xvfb-run nosetests \
-# --cover-erase \
-# --with-xunit \
-# --xunit-file=nosetests.xml \
-# --with-coverage \
-# --cover-package=lutris \
-# --cover-xml-file=coverage.xml
+# xvfb-run nosetests
}
package() {