summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6a7857785e2f..00938363a402 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
pkgname=luxcorerender
pkgver=2.1
-_alpha=4
-pkgrel=2
+_rel="beta1"
+pkgrel=3
pkgdesc="LuxCoreRender is a physically correct, unbiased rendering engine."
arch=('x86_64')
url="https://www.luxcorerender.org/"
@@ -14,16 +14,16 @@ makedepends=(git doxygen cmake python-pyside-tools opencl-headers)
conflicts=(luxrays-hg)
provides=(luxrays)
options=('!buildflags')
-source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${pkgver}alpha${_alpha}.tar.gz"
+source=("https://github.com/LuxCoreRender/LuxCore/archive/${pkgname}_v${pkgver}${_rel}.tar.gz"
"python.patch"
"glfw.patch"
)
-md5sums=('7255c3027aab84ef7bed084af1ba850b'
+md5sums=('ac04f8dea232ebafc619afed152dad56'
'21b963e5f66d2c8c6a50bebcf9f0fe07'
'624f2be4cb431f6a4cfcc968d6263ac2')
prepare() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}${_rel}
msg "python.patch"
patch -Np1 < ../python.patch
msg "glfw.patch"
@@ -31,14 +31,14 @@ prepare() {
}
build() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}${_rel}
mkdir -p build && cd build
cmake -DPYTHON_V=3 ..
make
}
package() {
- cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}alpha${_alpha}/build
+ cd ${srcdir}/LuxCore-${pkgname}_v${pkgver}${_rel}/build
install -d -m755 ${pkgdir}/usr/{bin,include,lib}
install -m755 bin/* ${pkgdir}/usr/bin