summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06758334d87d..a478f0db8d71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Comaintainer: bartus <aur@bartus.33mail.com>
_pyver=$(python -c "from sys import version_info; print(\"%d.%d\" % (version_info[0],version_info[1]))")
pkgname=luxrays-hg
-pkgver=3752+.36522ab16096+
-pkgrel=1
+pkgver=3755+.ceb10f796325+
+pkgrel=2
pkgdesc="Accelerate the ray intersection process by using GPUs"
arch=('x86_64')
url="http://www.luxrender.net/"
@@ -20,10 +20,13 @@ optdepends=('opencl-driver: OpenCL support' \
options=('staticlibs')
provides=('luxrays')
conflicts=('luxrays')
-source=('luxrays::hg+https://bitbucket.org/luxrender/luxrays#branch=default' \
- force_python3.diff)
+source=('luxrays::hg+https://bitbucket.org/luxrender/luxrays#branch=default'
+ force_python3.diff
+ embree2-bvh.patch
+)
md5sums=('SKIP'
- 'ba9a42dbe073009189c6d21845bff767')
+ 'ba9a42dbe073009189c6d21845bff767'
+ 'e6be00520ee90bdd24d1d7d0b31f3429')
pkgver() {
cd "$srcdir/luxrays"
@@ -35,15 +38,20 @@ prepare() {
# force python3 for boost
patch -Np1 < "$srcdir/force_python3.diff" || true
+ patch -Np1 -i ../embree2-bvh.patch
}
build() {
cd "$srcdir/luxrays"
+ mkdir -p build
+ cd build
- cmake . \
+ cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_SKIP_RPATH=ON \
-DLUXRAYS_DISABLE_OPENCL=OFF
+ # -DEMBREE_INCLUDE_PATH=/usr/include/embree-bvh_build \
+ # -DEMBREE_LIBRARY=/usr/lib/embree-bvh_build/libembree.a
# this sucks, but luxrays doesn't seem to honor CMAKE_*_LINKER_FLAGS
# thanks bartus from AUR for the fix
for file in `grep lboost_python -l -R ` ;do sed -i 's/$/ -lpython3/' $file ; done
@@ -51,12 +59,12 @@ build() {
}
package() {
- cd "$srcdir/luxrays"
+ cd "$srcdir/luxrays/build"
install -d -m755 "$pkgdir"/usr/{bin,include,lib}
install -m755 bin/* "$pkgdir"/usr/bin
install -m644 lib/* "$pkgdir"/usr/lib
- cp -a include "$pkgdir"/usr
+ cp -a ../include "$pkgdir"/usr
# install pyluxcore to the Python search path
install -d -m755 "$pkgdir"/usr/lib/python${_pyver}/