summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 802f14dcd9bc..3518cce08c4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=lxdui
pkgname=$_pkgname-git
-pkgver=2.1.1.0.636.c477657
+pkgver=0
pkgrel=1
srcver() {
@@ -35,6 +35,7 @@ depends=(lxd
)
makedepends=('python-virtualenv')
provides=(lxdui)
+conflicts=(lxdui)
install=lxdui.install
backup=(etc/lxdui/lxdui.conf
etc/lxdui/log.conf
@@ -51,9 +52,9 @@ source=($pkgname::git+https://github.com/AdaptiveScale/$_pkgname
sha256sums=('SKIP'
'e419e1ecb8bec84fd676e7a729d91b48065a3a7616956bc5356e64e6d8286eac'
'b149cf164d32659b95802d0e4e455e98736de0d0ece519c48eae2eb846c35f3c'
- 'ba3e1a27e38e63e283ea595480be375a70d5f24879ba4c2c4f3fe4dc28fbdee4'
+ '0f1eca29cbdfc2aeceeb37ece9d6cdfce19503307bd2de3803cf8de2b8139a2c'
'7487a9b77522a23b1be4c02961f46917d48b9c617d669843bbf26c4fd285d75d'
- 'bf8ecd2b10b70d90b8b7b9dd2d5b35a69cb2ed6fa6d7a7c310cc0648fa19e723')
+ '929c933ed0085d74972fd20c14f07b01ad4aaaff93c84897527868424447ef1f')
prepare()
{
@@ -80,11 +81,15 @@ package() {
find $pkgdir/usr/lib/$_pkgname/bin -type f -exec grep -q $pkgdir {} \; -exec sed -i "s:$pkgdir::g" {} \;
find $pkgdir/usr/lib/$_pkgname/lib -type d \( -name testsuite -o -name tests \) -exec rm -rf {} \; 2>/dev/null || true
+ install -dm755 $pkgdir/usr/bin
+ ln -s ../lib/$_pkgname/bin/lxdui $pkgdir/usr/bin/lxdui
+
install -Dm644 $_pkgname.conf $pkgdir/etc/$_pkgname/$_pkgname.conf
install -Dm644 $_pkgname.sysusers $pkgdir/usr/lib/sysusers.d/$_pkgname.conf
install -Dm644 $_pkgname.service $pkgdir/usr/lib/systemd/system/$_pkgname.service
install -Dm644 $_pkgname.tmpfiles $pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf
mv $pkgdir/usr/lib/$_pkgname/lib/python3.6/site-packages/LXDUI-$(srcver)-py3.6.egg/conf/* $pkgdir/etc/$_pkgname
+ chmod 600 $pkgdir/etc/$_pkgname/auth.conf
}