summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7105c2e73672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+### Maintainer: Gabriel Retana <isseigx at protonmail dot ch>
+
+pkgname=lxqt-arc-dark-theme-git
+pkgver=latest
+pkgrel=1
+pkgdesc="A dark theme for LXQt based on Arc"
+arch=('any')
+url="https://github.com/gabretana/lxqt-arc-dark-theme"
+license=('GPL')
+optdepends=('kvantum-theme-arc: recommended kvantum style')
+_theme='arc-dark'
+_repo='lxqt-arc-dark-theme'
+source=("git+https://github.com/gabretana/lxqt-arc-dark-theme.git")
+md5sums=('SKIP')
+
+pkgver() {
+ echo "$(git -C "${srcdir}/${_repo}" rev-list --count HEAD)"
+}
+
+package() {
+ install -d "${pkgdir}"/usr/share/lxqt/themes/"${_theme}"
+ cp -r "${srcdir}/${_repo}/${_theme}"/* "${pkgdir}"/usr/share/lxqt/themes/"${_theme}"/ --preserve=mode
+}