summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd3ae14c5dab..ed7956a39725 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,17 @@
_pkgname=lxqt-panel
pkgname=$_pkgname-git
-pkgver=0.10.0.129.g1c48664
+pkgver=0.10.0.143.g1c22479
pkgrel=1
pkgdesc='The LXQt desktop panel'
arch=('i686' 'x86_64')
url='https://github.com/lxde/lxqt-panel'
license=('GPL2')
-# Since https://github.com/lxde/lxqt-panel/pull/281, liblxqt-git is necessary
depends=(
- "kwindowsystem" "kguiaddons" "solid"
+ "alsa-lib" "libpulse" "lm_sensors" "libstatgrab" "libsysstat-git"
+ "kguiaddons" "solid"
"menu-cache" "libxcomposite" "lxmenu-data" "libdbusmenu-qt5"
- "liblxqt-git" "lxqt-globalkeys"
-)
-optdepends=(
- "alsa-lib: Recompile for Alsa support in volume control plugin"
- "libpulse: Recompile for PulseAudio support in volume control plugin"
- "lm_sensors: Recompile for Sensors (battery) plugin"
- "libstatgrab: Recompile for network and CPU monitor plugin"
+ "lxqt-globalkeys"
)
makedepends=("git" "cmake" "qt5-tools")
provides=("$_pkgname")
@@ -38,8 +32,7 @@ build() {
cd build
cmake "$srcdir/$_pkgname" \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DSYSSTAT_PLUGIN=No
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib
make
}