summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca82d47c5d43..4d5b160e9fed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,24 +9,28 @@ set -u
_pkgname=lynx
pkgname="${_pkgname}-current"
_basever='2.8.9'
-pkgver="${_basever}dev.6"
+pkgver="${_basever}dev.7"
pkgrel='2'
pkgdesc='A text browser for the World Wide Web (current development version)'
arch=('i686' 'x86_64')
-url='http://lynx.isc.org/'
+#url='http://lynx.isc.org/'
+url='http://lynx.invisible-island.net'
license=('GPL')
depends=('openssl' 'ncurses' 'libidn')
provides=("${_pkgname}=${_basever}")
conflicts=("${_pkgname}")
backup=('etc/lynx.cfg')
-_verwatch=("${url}current/" "/current/${_pkgname}\(.*\)\.tar\.bz2" 'l')
-source=("http://lynx.isc.org/current/${_pkgname}${pkgver}.tar.bz2") #{,.asc})
-sha256sums=('3e1f3e8c0df19de9b3d26d6f221b6789dab3ee1302c9cf7a888efcc186f373b5')
+_verwatch=("http://invisible-mirror.net/archives/lynx/tarballs/?C=M;O=D" "${_pkgname}\(.*\)\.tar\.bz2" 'l')
+#source=("http://lynx.isc.org/current/${_pkgname}${pkgver}.tar.bz2") #{,.asc})
+#_srcdir="lynx${_basever//./-}"
+_srcdir="lynx${pkgver}"
+source=("http://invisible-mirror.net/archives/lynx/tarballs/${_pkgname}${pkgver}.tar.bz2") #{,.asc})
+sha256sums=('8166827971488479c99fd52d6b3f731430b8af21285142de819d6ee6e5ed6fa9')
#validpgpkeys=('0AFD1FFEEA2EA063B959ACDA5DDF8FB7688E31A6')
prepare() {
set -u
- cd "${srcdir}/lynx${_basever//./-}"
+ cd "${_srcdir}"
./configure --prefix='/usr' \
--sysconfdir='/etc' \
--with-ssl='/usr' \
@@ -40,14 +44,14 @@ prepare() {
build() {
set -u
- cd "${srcdir}/lynx${_basever//./-}"
+ cd "${_srcdir}"
make -s # -j "$(nproc)" # not compatible with threaded make
set +u
}
package() {
set -u
- cd "${srcdir}/lynx${_basever//./-}"
+ cd "${_srcdir}"
make DESTDIR="${pkgdir}" install
# FS#20404 - points to local help
@@ -57,6 +61,7 @@ package() {
cp -rf 'lynx_help' "${pkgdir}/usr/share/doc/lynx"
set +u
# Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
+ # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
@@ -68,6 +73,6 @@ package() {
# A bunch of config instructions
#! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
# Not references to /bin
- #! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
+ #! pcre2grep -Ilr "(?<!usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
}
set +u