summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 754662cf839d..2878403a0824 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
# Maintainer: Fredy GarcĂ­a (frealgagu@gmail.com)
# Contributor: Pedro Gabriel (pedrogabriel@dcc.ufmg.br)
# Contributor: cookiengineer
+
pkgname=m64py
pkgver=0.2.4
-pkgrel=2
-pkgdesc="QT5 front-end for Mupen64Plus in Python"
+pkgrel=3
+pkgdesc="M64Py is a Qt5 front-end (GUI) for Mupen64Plus, a cross-platform plugin-based Nintendo 64 emulator"
arch=("any")
-url="http://m64py.sourceforge.net"
+url="https://github.com/mupen64plus/mupen64plus-ui-python"
license=("GPL")
-depends=(mupen64plus sdl2 python-pyqt5 python-pysdl2 desktop-file-utils libxkbcommon-x11)
-makedepends=(python-distribute)
-install='m64py.install'
-source=("https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/m64py-${pkgver}.tar.gz")
-md5sums=('5710db43f238ec4527634d69d9bacf0b')
+depends=("desktop-file-utils" "libxkbcommon-x11" "mupen64plus" "python-pyqt5" "python-pysdl2" "sdl2")
+makedepends=("python-distribute")
+install="${pkgname}.install"
+source=("https://github.com/mupen64plus/mupen64plus-ui-python/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=("38c175587f6bb1984586584f27faad72ac3db7fed4bbbbdf26b3c75bfd0a6ce4")
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --optimize=1 --prefix=/usr --root="${pkgdir}/"
}