summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10d1875bc329..37126c490f16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
pkgname='macos-icon-theme'
pkgver=4.1.5
-pkgrel=2
+pkgrel=3
pkgdesc='macOS Icons Theme'
arch=('any')
url='https://www.opendesktop.org/p/1102582/'
depends=('gtk-update-icon-cache')
-source=('https://dl.opendesktop.org/api/files/download/id/1510321229/macOS.tar.xz')
+
+# Hash and Timestamp
+_p="var \(hash = '\(.*\)\|timetamp = '\(.*\)\)';"
+read _s _t <<< $(echo -n $(curl -s $url | sed -n "s/$_p/\2\3/p"))
+
+source=("https://dl.opendesktop.org/api/files/downloadfile/id/1510321229/s/$_s/t/$_t/macOS.tar.xz")
md5sums=('056982040d0efdcf4fa93b0e5bc9bc3d')
prepare() {
- cd "$srcdir"
find -name '* *' -delete
cp macOS/status/symbolic/*.svg macOS/devices/symbolic
mv macOS/apps/128/accessories_calculator.png macOS/apps/128/accessories-calculator.png
}
package() {
- cd "$srcdir"
find */ -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/icons/{}" \;
}