summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e695a01b494
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Chanathip Srithanrat <axesd9@gmail.com>
+
+pkgname='macos-icon-theme'
+pkgver=3.5
+pkgrel=1
+pkgdesc='macOS iCons Theme'
+arch=('any')
+url='https://www.gnome-look.org/p/1102582/'
+depends=('gtk-update-icon-cache')
+source=('https://dl.opendesktop.org/api/files/download/id/1487473049/macOS%20iCon%20theme%20v3.5.tar.xz')
+md5sums=('9cfe3594b030236b68881208a3402074')
+_name="macOS iCon theme v$pkgver"
+
+prepare() {
+ cd "$srcdir/$_name"
+ find -name '* *' -delete
+}
+
+package() {
+ cd "$srcdir/$_name"
+ find */ -type f -exec install -Dm644 '{}' "$pkgdir/usr/share/icons/{}" \;
+}