summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..408d72119f06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Buce <dmbuce@gmail.com>
+
+pkgname=macrobe
+pkgver=0.r63.g5b910f4
+pkgver() {
+ cd "$srcdir/$pkgname"
+ if ! git describe --tags 2>/dev/null; then
+ echo "0.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+ fi | sed 's/-/.r/; s/-/./g'
+}
+pkgrel=1
+pkgdesc="Companion scripts for xmacro."
+arch=(any)
+url="https://github.com/DMBuce/macrobe"
+license=('GPL3')
+groups=()
+depends=(
+ xmacro
+ perl
+ bash
+)
+makedepends=('git')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=("$pkgname::git+https://github.com/DMBuce/${pkgname%-git}.git")
+#source=("$pkgname::git+ssh://git@mantrid/~/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname"
+ make prefix=/usr sysconfdir=/etc localstatedir=/var DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: