summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf9fe63858d9..5cd3c59f592e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: anon at sansorgan.es
pkgname=madagascar
-pkgver=3.0.1
-pkgrel=6
+pkgver=r14559.36030635e
+pkgrel=1
+epoch=1
pkgdesc="Multidimensional data analysis and reproducible computational experiments."
url=http://ahay.org/
license=('GPL2')
@@ -14,6 +15,12 @@ options=('strip')
source=($pkgname::git+https://github.com/ahay/src)
noextract=("$pkgname.tar.gz")
+pkgver(){
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
prepare() {
cd "$srcdir"
#bsdtar -xf $pkgname.tar.gz --strip-components=1