summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2414a6f6e45..05310e68f584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
_pkgname=magewell-pro-capture
pkgname=${_pkgname}-dkms
-pkgver=4227
+_pkgver=4236
+pkgver=1.3.0.4236
pkgrel=1
pkgdesc='Driver for Magewell Pro Capture Family'
arch=('x86_64')
@@ -10,13 +11,11 @@ url='https://www.magewell.com/downloads/pro-capture#/driver/linux-x86'
license=('unknown')
conflicts=("${_pkgname}")
depends=('dkms' 'alsa-lib')
-source=("ProCaptureForLinux_${pkgver}.tar.gz::https://www.magewell.com/files/drivers/ProCaptureForLinux_${pkgver}.tar.gz"
- "dkms.conf")
-sha256sums=('99538DD7C76408D85CCF71A02137484CFB3ABCF610C0881BA8C61DEAAC3465E2'
- '0ED4336FE8F5ECC42F6285ACC634B21BCF32137596BD2EF8A44D6936E7A78551')
+source=("https://www.magewell.com/files/drivers/ProCaptureForLinux_${_pkgver}.tar.gz")
+sha256sums=('e4683c3868608869395eb7667adfbe987971f10ede36140bd6e6883a0992cfd5')
package() {
- cd ProCaptureForLinux_${pkgver}
+ cd ProCaptureForLinux_${_pkgver}
install -Dm644 src/res/* -t ${pkgdir}/usr/share/ProCapture/res
sed -i 's#/usr/local/share/ProCapture/src/res#/usr/share/ProCapture/res#g' scripts/ProCapture.conf
@@ -26,7 +25,7 @@ package() {
install -Dm755 bin/mwcap-control_64 ${pkgdir}/usr/bin/mwcap-control
install -Dm755 bin/mwcap-info_64 ${pkgdir}/usr/bin/mwcap-info
- srcdir=${pkgdir}/usr/src/${_pkgname}-${pkgver}
- install -Dm644 ../dkms.conf src/Makefile src/ProCaptureLib_64.lib -t ${srcdir}
+ srcdir=${pkgdir}/usr/src/${_pkgname}-${_pkgver}
+ install -Dm644 src/dkms.conf src/Makefile src/ProCaptureLib_64.lib -t ${srcdir}
cp -r src/public src/sources ${srcdir}
}