summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71b1cb626670..38d784fb4da3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,21 @@
# Maintainer : Kr1ss $(echo \<kr1ss+x-yandex+com\>|sed s/\+/./g\;s/\-/@/)
# Upstream author : Roland Puntaier <roland [dot] puntaier [at] gmail [dot] com>
-# Upstream author : Luke Smith <luke [at] lukesmith [dot] xyz>
pkgname=mailwizard-git
+_name="${pkgname%-git}"
-pkgver() {
- cd "${pkgname%-git}"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-pkgver=r737.150b8b6
+pkgver() { git -C "$_name" describe --long | sed 's/^v//;s/-/.r/;s/-/./'; }
+pkgver=2.0.6.r0.g1a5962e
pkgrel=1
-pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords'
+pkgdesc='Configure neomutt, isync, getmail and msmtp with pass for passwords (POP3/SMTP)'
arch=('x86_64')
-url="https://github.com/rpuntaie/${pkgname%-git}"
+url="https://github.com/rpuntaie/$_name"
license=('GPL3')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" 'mutt-wizard')
+provides=("$_name")
+conflicts=("$_name" 'mutt-wizard')
makedepends=('git')
depends=('neomutt' 'isync' 'getmail6' 'msmtp' 'notmuch-runtime' 'pass' 'urlscan')
@@ -42,19 +39,19 @@ install=wizard.install
source=("git+$url"
'migrationhelper')
sha256sums=('SKIP'
- '34682620297727b9bf93670b84592050d59181e682d3867cd56aefedbd67243f')
+ '96471dc5a53af342cf14f5ec119df81509617f960c707d732781a24d9e2ed3c6')
#check() {
-# cd "${pkgname%-git}"
+# cd "$_name"
# ./dotests
#}
package() {
- cd "${pkgname%-git}"
+ cd "$_name"
make DESTDIR="$pkgdir" -s install
- install -m755 ../migrationhelper -t"$pkgdir/usr/share/${pkgname%-git}/"
- install -Dm644 README.rst -t"$pkgdir/usr/share/doc/${pkgname%-git}/"
+ install -m755 ../migrationhelper -t"$pkgdir/usr/share/$_name/"
+ install -Dm644 README.rst -t"$pkgdir/usr/share/doc/$_name/"
}